进入傍晚了,不想去散散步吗?
登录注册
2022-11-27 07:56:52

Spring Boot 3.0 发布啦但是我还是暂时放弃升级了

Spring Boot 3.0 发布啦但是我还是暂时放弃升级了

spring Boot3.0在2022年11月25号正式发布了3.0.0版本,作为喜欢追新的吃螃蟹的人,必须升级体验一把,但是我最后放弃了。

SpringBoot 3.0

最大的变化是 JDK17,你不能再抱着你的 JDK8 了,必须升级到 JDK17!然后其他要求和依赖也发生了巨大的变化:

  • Maven:如果你使用 Maven 构建那最低版本支持到 3.5
  • Gradle:如果你使用 Gradle 构建那最低版本支持到 7.5
  • Tomcat:Tomcat 10,Servlet 5.0
  • Spring Framework:6.0.2,嗯~直接到了Spring6
  • Spring Security:6.0.0 也直接到了6
  • Spring Data:2022.0.0 这个里面有好多,但基本也都升级了,我使用的 spring-data-elasticsearch 就升级到了5.0,也删除了大量过时的内容

我升级遇到的问题

为什么我暂时放弃升级了呢,我遇到了很多问题,我先罗列一下,给各位趟趟坑。

JDK17

万年的 JDK8 终于要升级了,最低升级到 JDK17,虽然向下兼容,但是很多配置、CICD的基础环境,都需要大量的修改和调试。

Tomcat10

首先,由于升级到了 Tomcat10,那么 Servlet 也到了 5.0,遇到的问题是最多的,首先就是包名的变化!比如之前的 javax.servlet.http.HttpServlet,没有了?嗯!它改名了!现在叫 jakarta.servlet.http.HttpServlet,你以为批量替换就行了?还是太年轻,你的源码虽然改了,但是你依赖的其他库还没有改,这就导致虽然你的代码不报错,但一运行起来,其他依赖库中的代码就是满世界冒火,各种报找不到类!这也是我主要暂时放弃升级的原因,还是需要时间等待其他库去适配,如果其他库停止维护了没人适配,那么还需要自己编译构建修改版的库包,工作量可能巨大,代价太大了。

SpringData 2022

我使用了 elasticsearch,升级以后发现之前的好多方法和类都没有了,学习和调试成本也比较高,尝试修改了一下虽然不报错了,但也需要大量的测试才敢发布,这个变动实在太大了。

总结

来到 Spring Boot 3.0 以后,感觉完全是全新的世界,JDK17、Tomcat10、Servlet 5.0,既熟悉又陌生,我感觉各个老系统应该不会选择升级,变化太大,直接旱地拔葱起飞的感觉,想要普及可能还需要几年的时间,眼下,我最头疼的是我之前的那些开源库,如何兼容 SpringBoot 2.x和3.x 两个版本,主要差别就是 servlet 的包名都变了,头大。

评论与留言

以下内容均由网友提交发布,版权与真实性无法查证,请自行辨别。
本站有缓存策略,时间约2小时后能看到您的评论。本站使用自动审核机制,如果您的内容包含广告/谩骂/恐怖/暴力/涉政等不和谐内容将无法展示!
微信订阅号
扫码关注「任霏博客」微信订阅号
反馈与讨论
感谢您的关注与反馈
如果您发现了BUG、安全漏洞、或者希望讨论技术内容,请点击下方链接对我进行反馈。
feedback