2021-04-07 16:04:58

Debian HTML清理库发现跨站点脚本漏洞,需要尽快升级


Debian HTML清理库发现跨站点脚本漏洞,需要尽快升级

python-bleach是一个基于白名单、通过转义或去除标签和属性的方式,来对HTML文本净化的python库。

4月6日,Debian发布了安全更新,修复了HTML清理库python bleach 中发现的跨站点脚本漏洞。以下是漏洞详情:

漏洞详情

来源:https://lists.debian.org/debian-lts-announce/2021/04/msg00006.html

CVE-2021-23980 

严重程度: 重要

XSS攻击通常指的是通过利用网页开发时留下的漏洞,通过巧妙的方法注入恶意指令代码到网页,使用户加载并执行攻击者恶意制造的网页程序。

在python bleach中发现存在跨站点脚本(XSS)漏洞。通过允许的数学或svg;p或br; 和样式,标题,noscript,脚本,textarea,noframes,iframe或带有strip_comments = False的xmp标签造成XSS攻击。

受影响产品及版本

上述漏洞影响Debian9 Stretch python-bleach 2.0-1 + deb9u1之前版本

解决方案

对于Debian 9 Stretch,此问题已在版本python-bleach 2.0-1 + deb9u1中修复,建议及时更新python-bleach软件包。

查看更多漏洞信息 以及升级请访问官网:https://www.debian.org/lts/security/


商业用途请联系作者获得授权。
版权声明:本文转载自「TechWeb.com.cn」,版权归原所有者。
原文链接:http://www.techweb.com.cn/cloud/2021-04-07/2833879.shtml
评论与留言
以下内容均由网友提交发布,版权与真实性无法查证,请自行辨别。

本站有缓存策略,时间约2小时后能看到您的评论。本站使用自动审核机制,如果您的内容包含广告/谩骂/恐怖/暴力/涉政等不和谐内容将无法展示!


本站有缓存策略,时间约2小时后能看到您的评论。本站使用自动审核机制,如果您的内容包含广告/谩骂/恐怖/暴力/涉政等不和谐内容将无法展示!

关注任霏博客
扫码关注「任霏博客」微信订阅号
微博:任霏博客网
Twitter:@renfeii
Facebook:任霏